RaspPiB+ & Amp+ on fresh Raspbian = no sound?

Hi guys..

I just received a new Raspberry Pi B+ and a Amp+.. So setup Squeezeplug 7.5 (this is based on Raspbian), ran rpi update, configured modules blacklist and loads, seems all fine. The device gets recognized and is there, mplayer seems to be able to play to it - but somehow nothing comes out of my speakers ;-(

So, let's see.. aplay -l shows:

root@squeezeplug:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_amp], device 0: HifiBerry AMP HiFi tas5713-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0

OK; so old-style alsa address is 1.0.. did that in /etc/asound.conf:

pcm.!default {
type hw card 1
ctl.!default {
type hw card 1

first i tried using squeezelite (a squeezebox player), running with the argument -o sysdefault:CARD=sndrpihifiberry. squeezelite runs, no error output, all seems fine - but no output..

then i tried with mplayer:
mplayer -ao alsa:device=hw=1.0 file.mp3

--> and yes, i looked into alsamixer, it's on volume 80%, i also tried to set it with "alsamixer sset..".. no lock ;-(

i think driver-wise, all should be fine. mplayer complains about "resource busy" when trying to play something while squeezelite is running.. that's a good sign..

so - why no sound? i try to drive a set of old Technics speakers, 6 ohm, up to 100w. i also tried to put on a small harman kardon speaker (4ohm), doesn't work either..
i checked twice that + and - (speaker cables) are correct, the speakers and cables are known to work.. hmm.. i'm unsure what to try next.. any ideas?

as power source, i use a usb logitech plug i've had laying around, 15V 1A output.. could that be a problem?

thanks for any hints! ;-)


Please sign in to leave a comment.