0

Digi+ and PiMusicBox SYNC error

I tried to get the Digi+ working with the PiMusicBox several times. It always ended in frustration after several hours of work. Today I saw on the "supported platforms" that support for PiMusicBox using Digi+ changed from "soon" to "yes" so I tried again. But still no success. Here is what I did:

Installed Digi+ Module and checked it using the test image. Test sound is played correctly via spdif!

Installed latest Pi Musicbox SD Card Image (musicbox0.5.1rc.img)
changed settings.ini: output = hifiberry_digi
booted from SD Card. HDMI output is selected automatically and works!

updated kernel:
sudo apt-get install rpi-update
sudo rpi-update




checked /etc/modprobe.d/raspi-blacklist.conf:
blacklist spi-bcm2708
#blacklist i2c-bcm2708




modified /etc/modules (snd_soc_bcm2708_i2s already present):
snd_bcm2835
snd_soc_bcm2708
snd_soc_hifiberry_digi
bcm2708_dmaengine
ipv6
bcm2708_wdog




reboot

hifiberry_digi is detected but sound output is still set to HDMI (ignoring the digi+ although this is explicitly set in settings.ini)

aplay lists following devices:
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 7/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0




checked /opt/musicbox/setsound.sh - the script looks for the device identification snd_rpi_hifiberry_digi but the id snd_hifiberry_digi supplied is.
elif [[ ${dev[1]} == "snd-rpi-hifiberry-digi" ]]; then
changed to:
elif [[ ${dev[1]} == "snd-hifiberry-digi" ]]; then

reboot

hifiberry_digi is detected AND selected as output device.

NO SOUND. Instead an error is displayed:
bcm2708-i2s bcm2708-i2s.0: I2S SYNC error!

removed snd_bcm2835 from /etc/modules - still the same error

changed from snd_soc_bcm2708 to snd_soc_bcm2708_i2s in /etc/modules - still the same error

switched between spdif and toslink connection - still the same error

This is getting frustrating - please help!

16 comments

Please sign in to leave a comment.