0

Rpi B with Hifiberry Digi using pulseaudio

Hy,
I try to get my hifiberry divi work with pulseaudio. I want to realize a bluetooth audio device with Rpi and hifiberry. the hifiberry digi works perfectly with also (I also use squeezelite) but i have no chance to use it with pulse audio

Following list is available for the cards wich pacmd


pi@RaspWZ ~ $ pacmd list-cards
Welcome to PulseAudio! Use "help" for usage information.
>>> 2 card(s) available.
index: 0
name: <alsa_card.platform-bcm2835_AUD0.0>
driver: <module-alsa-card.c>
owner module: 4
properties:
alsa.card = "0"
alsa.card_name = "bcm2835 ALSA"
alsa.long_card_name = "bcm2835 ALSA"
alsa.driver_name = "snd_bcm2835"
device.bus_path = "platform-bcm2835_AUD0.0"
sysfs.path = "/devices/platform/bcm2835_AUD0.0/sound/card0"
device.string = "0"
device.description = "bcm2835 ALSA"
module-udev-detect.discovered = "1"
device.icon_name = "audio-card"
profiles:
output:analog-mono: Analog Mono Output (priority 100)
output:analog-stereo: Analog Stereo Output (priority 6000)
off: Off (priority 0)
active profile: <output:analog-stereo>
sinks:
alsa_output.platform-bcm2835_AUD0.0.analog-stereo/#0: bcm2835 ALSA Analog Stereo
sources:
alsa_output.platform-bcm2835_AUD0.0.analog-stereo.monitor/#0: Monitor of bcm2835 ALSA Analog Stereo
ports:
analog-output: Analog Output (priority 9900, available: unknown)
properties:

index: 1
name: <bluez_card.10_68_3F_5A_BD_72>
driver: <module-bluetooth-device.c>
owner module: 6
properties:
device.description = "mob"
device.string = "10:68:3F:5A:BD:72"
device.api = "bluez"
device.class = "sound"
device.bus = "bluetooth"
bluez.path = "/org/bluez/2198/hci0/dev_10_68_3F_5A_BD_72"
bluez.class = "0x5a020c"
bluez.name = "mobü"
device.icon_name = "audio-card-bluetooth"
profiles:
a2dp_source: High Fidelity Capture (A2DP) (priority 10)
hfgw: Handsfree Gateway (priority 20)
off: Off (priority 0)
active profile: <a2dp_source>
sources:
bluez_source.10_68_3F_5A_BD_72/#1: mob
ports:



List of the cards on alas

pi@RaspWZ ~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 7/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: HifiBerry Digi HiFi wm8804-spdif-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0



In the script for to realize the bluetooth-audio functionality is following line
AUDIOSINK="alsa_output.platform-bcm2835_AUD0.0.analog-stereo"

At the moment I have no idea how to change it for using the hifiberry digi.

Thanks for your help!
Best regards,
Roland

1 comment

Please sign in to leave a comment.