0

Digi+ with RuneAudio

Hi

I can't get the Digi+ to work with RuneAudio even after updating the kernel.
I chose HifiBerry Digi in Settings but it does not appear in MPD

###### System info ######
Linux version 3.12.29-1-ARCH (nobody@root-armv6-copy) (gcc version 4.8.2 20131219 (prerelease) (GCC) ) #1 PREEMPT Tue Oct 7 07:03:53 MDT 2014

PLAYBACK devices: (aplay -l)
--------------------------------------------------
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0

###### Loaded kernel modules ######
Module Size Used by
snd_soc_hifiberry_digi 2596 0
snd_soc_pcm5102a 1414 0
snd_soc_tas5713 5597 0
snd_soc_wm8804 7940 0
cfg80211 440137 0
8192cu 546061 0
snd_soc_bcm2708_i2s 6202 0
regmap_mmio 2838 1 snd_soc_bcm2708_i2s
snd_soc_core 155980 5 snd_soc_wm8804,snd_soc_hifiberry_digi,snd_soc_tas5713,snd_soc_pcm5102a,snd_soc_bcm2708_i2s
leds_gpio 2142 0
led_class 4162 1 leds_gpio
snd_compress 8351 1 snd_soc_core
snd_pcm_dmaengine 5533 1 snd_soc_core
regmap_spi 1941 2 snd_soc_wm8804,snd_soc_core
spi_bcm2708 4844 0
regmap_i2c 1685 3 snd_soc_wm8804,snd_soc_core,snd_soc_tas5713
i2c_bcm2708 4895 0
snd_bcm2835 19609 0
snd_pcm 81802 3 snd_bcm2835,snd_soc_core,snd_pcm_dmaengine
snd_page_alloc 5192 1 snd_pcm
snd_timer 20370 1 snd_pcm
snd 62046 5 snd_bcm2835,snd_soc_core,snd_timer,snd_pcm,snd_compress
bcm2708_rng 1044 0
rng_core 4159 1 bcm2708_rng
ipv6 320186 0

[ 4.563675] EXT4-fs (mmcblk0p5): re-mounted. Opts: nouser_xattr,errors=remount-ro
[ 5.804386] systemd-udevd[89]: starting version 216
[ 6.722041] bcm2708_i2c_init_pinmode(1,2)
[ 6.722070] bcm2708_i2c_init_pinmode(1,3)
[ 6.722754] bcm2708_i2c bcm2708_i2c.1: BSC1 Controller at 0x20804000 (irq 79) (baudrate 100000)
[ 6.764078] bcm2708_spi bcm2708_spi.0: master is unqueued, this is deprecated
[ 6.766035] bcm2708_spi bcm2708_spi.0: SPI Controller at 0x20204000 (irq 80)
[ 7.111409] bcm2708-i2s bcm2708-i2s.0: Failed to create debugfs directory
[ 8.980734] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[ 9.840394] cfg80211: Calling CRDA to update world regulatory domain
[ 10.569227] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
[ 10.644499] usbcore: registered new interface driver rtl8192cu
[ 12.940709] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[ 13.158226] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[ 14.666012] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
[ 33.748654] wm8804 1-003b: Failed to read device ID: -1
[ 33.748689] wm8804 1-003b: ASoC: failed to probe CODEC -1
[ 33.748777] snd-hifiberry-digi snd-hifiberry-digi.0: ASoC: failed to instantiate card -1
[ 33.748870] snd-hifiberry-digi snd-hifiberry-digi.0: snd_soc_register_card() failed: -1
[ 33.748912] snd-hifiberry-digi: probe of snd-hifiberry-digi.0 failed with error -1



I have not made any manual changes to any files.

Your help is much appreciated

1 comment

Please sign in to leave a comment.