0

Unable to play sound with hifiberry Digit

Hello

I usualy use Linux Mint but I try to install a HIFI solution with a Synology NAS and a PS Audio Nuwave DAC. So Raspberry Pi and Hifiberry should met the goal!

I meet a problem with my hifiberry digi configuration.
I received my hifiberry board few weeks ago and I only tried it a cupple of days ago.

My Raspberry Pi runs under a Raspbian for hifi with berryboot in order to use Raspbmc for media center:
$ uname -a
Linux raspberrypi 3.6.11-rpi-aufs #1 PREEMPT Sat Sep 7 23:10:27 CEST 2013 armv6l GNU/Linux



I followed guide to solder the P5 connector and to install the software configuration.
Today the green LED on the hifiberry board is switched on but I can't obtain any signal by optical link…

I ran rpi-update with the following result:
$ sudo rpi-update
*** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
*** Performing self-update
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 135 100 135 0 0 214 0 --:--:-- --:--:-- --:--:-- 292
100 7026 100 7026 0 0 7764 0 --:--:-- --:--:-- --:--:-- 7764
*** Relaunching after update
*** Raspberry Pi firmware updater by Hexxeh, enhanced by AndrewS and Dom
*** Your firmware is already up to date



I ran successfully too:
$ sudo apt-get update
$ sudo apt-get upgrade



I have added the following modules in /etc/modules:
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.
# Parameters can be specified after the module name.

snd-bcm2835
snd_soc_bcm2708_i2s
bcm2708_dmaengine
snd_soc_wm8804
snd_soc_hifiberry_digi
snd_soc_bcm2708



I can't find the hifiberry digi as sound card:
$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7



But when I boot the raspberry pi I have the following message:
[info] Loading kernel module snd_soc_bcm2708_i2s
Fatal: module snd_soc_bcm2708_i2s not found


The answer is the same for each new module (snd_soc_bcm2708_i2s, bcm2708_dmaengine, snd_soc_wm8804, snd_soc_hifiberry_digi, snd_soc_bcm2708).

After this try, I tried to boot on a new SD Card with your testtone_digi.img. The test was ok, the optical output is actived. But I can't install MPD, MPC and other things I need to play music from this distribution.

Furthermore aplay can't play any music with the Testtone-digi.img distribution:
$ aplay /media/music/test.mp3
Playing raw data '/media/music/test.mp3' : Unsigned 8 bit, Rate 8000 Hz, Mono
aplay: set_params:1145: Unable to install hw params:
ACCESS: RW_INTERLEAVED
FORMAT: U8
SUBFORMAT: STD
SAMPLE_BITS: 8
FRAME_BITS: 8
CHANNELS: 1
RATE: 8000
PERIOD_TIME: 125000
PERIOD_SIZE: 1000
PERIOD_BYTES: 1000
PERIODS: 4
BUFFER_TIME: 500000
BUFFER_SIZE: 4000
BUFFER_BYTES: 4000
TICK_TIME: 0


Have you any idea of what I have done wrong on both Raspbian+Berryboot and/or testtone_digi and how to solve it?

Thanks

Gaetan

4 comments

Please sign in to leave a comment.