0

Disabling power saving or auto-mute to avoid popping on audio start?

Hi there,

I have an Hifiberry DAC+ mounted on my Pi3.

The problem is that it produces a very noticeable poping sound when it starts playing audio from ANY program using the ALSA API (RetroArch, omxplayer, Scummvm...)

I have came to the conclussion that it only happens at start, so it may be related to power-saving features (the DAC is muted if no audio is being sent to it I guess). Is there a way to disable that so no popping is hear?

There should be no popping after the system initializes ALSA...

Some other drivers allow this, like the Intel HDA: the intel hda kernel module allows these parameters:

options snd_hda_intel power_save=0 power_save_controller=N

Is there something similar for the hifiberry kernel modules??

10 comments

Please sign in to leave a comment.