0

Digi+ Pro with Jessie - no mixer controls

Hello,

I got the Digi+ pro in and have been trying to properly configure the sound to no avail. I am using Raspbian Jessie (The Jan 11th, 2017 release: 4.4.34-v7+),  I followed all the instructions found here:

https://support.hifiberry.com/hc/en-us/articles/205377651-Configuring-Linux-4-x-or-higher

At the end of the guide, I was able to get sound out of the digi+ pro, but I cannot change the volume in the software. All the alsamixer controls are missing. What I mean by that is that the speaker icon in the upper-right is greyed-out and does not allow the control of any volume control, but DOES show "snd_rpi_hifiberry_digi" as the selected card when I right click.
Also, when I run 'alsamixer', I cannot find any mixer controls for the hifiberry card.

I've tried lots of Googling, but can't find any discussion about my specific issue. Meaning the fault is probably mine? 

My question: How can I get the mixer controls for the digi+pro in jessie?

Output of aplay -l :

card 0: sndrpihifiberry [snd_rpi_hifiberry_digi], device 0: Hifiberry Digi+ Pro HiFi wm8804-spdif-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

3 comments

Please sign in to leave a comment.