0

DAC+ Pro +BBC on PCP drives PiCorePlayer to Deathloop

Hi,

I have an RPi 2B with DAC+ Pro. This has worked well for about a year, but recently after upgrading some of the software, I've started having a problem in a very particular situation. I've not been able to go back to a working setup unfortunately.

Set up: picoreplayer 3.11 (kernel 4.4.39), LMS 7.9.0 nightly on Windows Server 2012R2, with BBC iPlayer plugin 1.5.3 (outside of the UK).

Local music plays fine. Most streams play fine, both MP3 and AAC.

But playing a BBC stream (both live and on demand) hangs the RPi (ping, web server and ssh become inaccessible or extremely slow; if I manage to get iperf3 running on the RPi it goes from ~60 Mb/s to 20 kb/s). The music stutters and squeezelite does not respond to LMS anymore.

The reason I am posting here is if I change the audio device to the internal audio jack, everything is ok. Switching to slave mode (i.e. RPi clocks) does not help.

Another RPi running squeezelite on LibreElec keeps on working fine even when the DAC+ device is stuttering.

I've tried changing versions of various components, including running the LMS on board of the RPi aabd chanign version of squeezelite (both including and excluding ffmpeg) to no avail.

This is what I get when I run dmesg

[   10.430809] snd-rpi-hifiberry-dacplus soc:sound: ASoC: CODEC DAI pcm512x-hifi not registered
[   10.430840] snd-rpi-hifiberry-dacplus soc:sound: snd_soc_register_card() failed: -517
[   10.525181] snd-rpi-hifiberry-dacplus soc:sound: pcm512x-hifi <-> 3f203000.i2s mapping ok

I'm at a complete loss. It seems to be an interaction between all these components and the DAC+ Pro and I am not sure what else I can try to fix this.

1 comment

Please sign in to leave a comment.