0

Basic configuration of digi+ pro

 So, I'm setting up my first Raspberry Pi. I'm running plain rasbian and everything is working fine, except my digi+ pro. I want to run my audio from the RP via optical output, but I can't get any sound. In the audio device options in rasbian I find an option to switch the sound card from bcm2835 ALSA to snd_rpi_hifiberry_digi (alsa mixer). When I switch this I can even find an select control option that allows me to specify the tx source as S/PDIF RX. All looking good, but when I select all this, it not only changes nothing as far as the lack of sound, but when I check back all the settings have been reset to bcm2835. Setting the hifiberry-digi alsa mixer as "default" doesn't have any effect. The internets are awash with various fixes that seem sort of kind of related, but I don't want to get into a lot of messing around not being sure the best way to fix this. I would prefer the most straightforward and foolproof way to set things up so that everything passes through the digi + pro's optical output. 

Clearly I'm not a master of the command line but once upon a time I spent a good year or two using various Linux distributions as my main OS, so I can handle a bit of fiddling... I'd just rather avoid it. 

Grateful for any suggestions!

2 comments

Please sign in to leave a comment.