Hifiberry Amp2 + Volumio - Sound stops


I have a problem with a project with volumio and maybe here i can find help.

I run volumio, Ver. 2.x, on a Raspberry Pi 3B+. The Hifiberry Amp2 is connected to the Pi.
I connected the Hifiberry with the Pi via short Jumper wire cables.

Also, there is a Waveshare-Display (13.3 inch) connected to the display.
Everything runs fine.

I also run a python script which runs a motor on the device.
The motor has ist own power supply, so that it is not powered by the pi.
When i run music after the startup, before i run the motor, theres sound/ music.
It works. But when i than start the motor, the sound stops and doesnt come back.

When, after starting the pi, i first run the motor and then play music, theres no sound.
Volumio shows that music is played, but there is no sound.

I first powered the Pi via the Hifiberry amp2. After i recognized the problem, i drove the pi with an own power supply and the Hifiberry Amp2 with an own powersupply. I removed the 5V and 3.3V connections between the Pi and the hifiberry, to prevent a problem from this.
Everything works like before, but still the exact same problem.

I use none of this GPIOs, that are needed from the Hifiberry, for the motor:

“GPIO2-3 (pins 3 and 5) are used by our products for configuration. If you are experienced with I2C, you might add other slave devices. If you a a novice, we don’t recommend this at all.
GPIOs 18-21 (pins 12, 35, 38 and 40) are used for the sound interface. You can’t use these for any other purpose.
GPIO4 is used to control the MUTE function of the power stage. Pulling it to low will mute the output.”
They are all connected from the Pi to the Hifiberry.

Does anyone have an Idea?


Thanks a lot in advance!


Please sign in to leave a comment.